Now About Social Code
aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-10-04 20:53:17 +0100
committerLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-10-04 20:53:17 +0100
commitbe71bf80d290c98c0f6a66d3dcab28515b4ea371 (patch)
treed936090c5b5c9435febfe220770ff7f25399a235 /src/meson.build
Initial commit
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..3225adc
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,42 @@
+pkgdatadir = get_option('prefix') / get_option('datadir') / meson.project_name()
+moduledir = pkgdatadir / 'weegtk'
+gnome = import('gnome')
+
+gnome.compile_resources('weegtk',
+ 'weegtk.gresource.xml',
+ gresource_bundle: true,
+ install: true,
+ install_dir: pkgdatadir,
+)
+
+python = import('python')
+
+conf = configuration_data()
+conf.set('PYTHON', python.find_installation('python3').full_path())
+conf.set('VERSION', meson.project_version())
+conf.set('localedir', get_option('prefix') / get_option('localedir'))
+conf.set('pkgdatadir', pkgdatadir)
+
+configure_file(
+ input: 'weegtk.in',
+ output: 'weegtk',
+ configuration: conf,
+ install: true,
+ install_dir: get_option('bindir'),
+ install_mode: 'r-xr-xr-x'
+)
+
+weegtk_sources = [
+ '__init__.py',
+ 'main.py',
+ 'window.py',
+ 'config.py',
+ 'chat.py',
+ 'message.py',
+ 'preferences.py',
+ 'relay/network.py',
+ 'relay/protocol.py',
+ 'relay/color.py'
+]
+
+install_data(weegtk_sources, install_dir: moduledir)