Now About Social Code
summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-08-02 23:33:44 +0100
committerLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-08-02 23:33:44 +0100
commit4c29e4b83e52f1e4afa3a8b4784be046592d8e4c (patch)
tree179cef1e7e0ed7e1421d83807f55eaa54bba03c0 /meson.build
parentc0cb2a22e7237c02df614f1994bd6acebfd23125 (diff)
drv: Add custom userspace driver
Add userspace driver that we will eventually use to try and replay the command dumps coming from the wrap library.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ce159cf..f27f96f 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,11 @@ if ddk_path == ''
error('ddk-path is required')
endif
+compiler = meson.get_compiler('c')
+libdrm_path = '/home/lfryzek/Documents/projects/hw/ci20/images/rootfs_2015_09_09/usr/lib/mipsel-linux-gnu/sgx'
+libdrm = compiler.find_library('libdrm',
+ dirs: libdrm_path)
+
incs = [
ddk_path + '/services4/srvkm/hwdefs',
ddk_path + '/include4',
@@ -32,3 +37,9 @@ shared_library('wrap',
build_by_default: true,
include_directories: incs,
dependencies: dl)
+
+executable('drv',
+ 'src/drv.c',
+ build_by_default: true,
+ include_directories: incs,
+ dependencies: libdrm)