Now About Social Code
summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f27f96f..7c90e0b 100644
--- a/meson.build
+++ b/meson.build
@@ -5,13 +5,17 @@ add_project_arguments('-D_GNU_SOURCE', language: 'c')
dl = dependency('dl')
ddk_path = get_option('ddk-path')
-
if ddk_path == ''
error('ddk-path is required')
endif
+rootfs_path = get_option('rootfs-path')
+if rootfs_path == ''
+ error('rootfs-path is required')
+endif
+
compiler = meson.get_compiler('c')
-libdrm_path = '/home/lfryzek/Documents/projects/hw/ci20/images/rootfs_2015_09_09/usr/lib/mipsel-linux-gnu/sgx'
+libdrm_path = rootfs_path + '/usr/lib/mipsel-linux-gnu/sgx'
libdrm = compiler.find_library('libdrm',
dirs: libdrm_path)