Now About Social Code
summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-08-02 23:39:27 +0100
committerLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-08-02 23:39:27 +0100
commite2434d86f69c7fac1894ff321bc06f1f5ef085ca (patch)
treedcccc755d5a029054f64dc69677b39b00c46b580 /meson.build
parent4c29e4b83e52f1e4afa3a8b4784be046592d8e4c (diff)
meson: Make rootfs path a configuration variable
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f27f96f..7c90e0b 100644
--- a/meson.build
+++ b/meson.build
@@ -5,13 +5,17 @@ add_project_arguments('-D_GNU_SOURCE', language: 'c')
dl = dependency('dl')
ddk_path = get_option('ddk-path')
-
if ddk_path == ''
error('ddk-path is required')
endif
+rootfs_path = get_option('rootfs-path')
+if rootfs_path == ''
+ error('rootfs-path is required')
+endif
+
compiler = meson.get_compiler('c')
-libdrm_path = '/home/lfryzek/Documents/projects/hw/ci20/images/rootfs_2015_09_09/usr/lib/mipsel-linux-gnu/sgx'
+libdrm_path = rootfs_path + '/usr/lib/mipsel-linux-gnu/sgx'
libdrm = compiler.find_library('libdrm',
dirs: libdrm_path)