Now About Social Code
aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-10-04 20:53:17 +0100
committerLucas Fryzek <lucas.fryzek@fryzekconcepts.com>2024-10-04 20:53:17 +0100
commitbe71bf80d290c98c0f6a66d3dcab28515b4ea371 (patch)
treed936090c5b5c9435febfe220770ff7f25399a235 /meson.build
Initial commit
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..bfefd93
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,18 @@
+project('weegtk',
+ version: '0.1.0',
+ meson_version: '>= 1.0.0',
+ default_options: [ 'warning_level=2', 'werror=false', ],
+)
+
+i18n = import('i18n')
+gnome = import('gnome')
+
+subdir('data')
+subdir('src')
+subdir('po')
+
+gnome.post_install(
+ glib_compile_schemas: true,
+ gtk_update_icon_cache: true,
+ update_desktop_database: true,
+)